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Installing Info-Explorer
Info Explorer is installed by executing the EXE program downloaded from the Orchid website (www.orch-
id.systems) .
InstallShield will execute and guide you through the installation steps.

Note: You can change the default installation directory by clicking on the Change button and browsing to a
new directory if required.

The following features are part of the installation process:
· Option to install with 30 day grace period.
· Option to install with product activation code.

Tip: Regarding Info Explorer installation.
If installing with a 30 day grace period, additional re-installations will not extend the grace period.
Re-installations over-write existing installations on the target directory.
If a valid installation already exists, the install process will not prompt for product registration and activation
details.
You can also choose to Remove a prior version before installing the latest version.
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Register Info-Explorer
If you are using Info-Explorer Lite (free version of Info-Explorer), you can apply for an activation code to
continue using the demonstration cubes after the 30 day trial. See below
With Info-Explorer Lite, you can only open and refresh Orchid demo cubes available from Info-Explorer menu >
Download sample cubes or the Orchid website.

Other limitations of Info-Explorer Lite include:

You cannot "Create Cube"

You can only view a single query cube at one time

Result sets not being able to be exported to Excel, CSV or HTML.

The cube SQL query cannot be amended

Note: Contact your Sage 300 business partner to purchase Info Explorer Full licence to create your own
cubes, modify the queries or Info Explorer Write Back for writeback functionality.

To request an activation code:

From Info-Explorer, Click File > Enter Registration code
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Gather the required information and click on the "get one here" hyperlink and complete the web-site
registration form on https://www.orchid.systems/resources/info-explorer-registration-form. An
activation code will be sent to you within 48 hours.
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When you have received your activation code

Click File > Enter Registration code and copy and paste the activation code sent by Orchid Sys-
tems in the Activation Code box, and click "activate"
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Info-Explorer - Getting Started
To run Info Explorer, Start > All Programs > Info-Explorer. You can add a shortcut to the taskbar or to the
desktop. Click Open Cube or File > Open and open one of the demonstration cubes.

Note:
if you are using Info-Explorer Lite, then "create cube", "export to csv", "export to HTML" , "export to MS Excel"
and "Worksets" are not available.
Worksets and Writeback are only available if the Info Explorer - Write back licence has been purchased and
activated. If you are using "info-Explorer - Full", then "Worksets" and writeback are not available.

Tip:
Process Scheduler Level 1 is required to refresh and distribute cubes automatically.
Refer to Process Scheduler documentation for details on how to refresh the Info Explorer automatically

The Info-Explorer > File allows you to 

Open an existing cube

Create a new cube

Save an existing cube

Save the existing cube as a new file name

Close the open cube

Download Sample Cubes

Enter your Info-Explorer registration code

Read the release notes in the About option

To open an existing cube, click File>Open File and specify the file path and cube name accordingly, or
select the required document from the Recent Documents list.
To create a new cube, click File>Create and follow the prompts to connect to a database and define the
required query.
To Save, Save as or Close an open cube, the appropriate options can be selected from the File menu.
To enter your registration code, select File > Enter Registration Code.
To read the release notes and access latest Product Updates, select File >About.

Info-Explorer - Getting Started 8 of 82



Orchid Modules

Download Sample Cubes
From Info-Explorer, Click File > Download Sample Cubes
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To download the cube, click on the cube you would like, this will open the cube and to save go to File >

Save as . and choose where to save the cube.
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Open a cube

To open a cube, go File>Open . , and select the .cubx file.

If you openmultiple cubes files, you will havemultiple tabs, one per cube file. The asterix "*" beside a
cube file name indicates unsaved changes have beenmade. If you close this cube file without saving, you
will be prompted if you want to loose the changes.  
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Save a cube

To save a new configuration of a cube, click File>Save or click on (to overwrite the existing cube)
or File> Save As (to create a new cube and provide a new file name)

You should save a cube after

you have configured your cube to point to a new database

new formatting has been applied

a new cube has been created

a new view has been created

a new chart has been created

a new dashboard has been created

an existing view, chart or dashboard has been amended or re-configured

the data has been refreshed
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if these changes are required to be preserved

Close a cube

will close the currently active cube.
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Change connection details
Info-Explorer connects to Sage 300 or other SQL Server and ODBC databases. To connect to your databases,
review the content below.

Important! if you are using Info-Explorer Lite, you can only connect to databases and use the queries
defined in Orchid's demo cube.

Configure to a different database 14

Create a new connection 15

Configure to a different database

To configure an existing cube to a different database, select Properties , click on the
appropriate connection and amend the appropriate details:

Database Type

Database User ID

Database Password

Server / Datasource

Database

It is recommended to click "test connection" to verify your details.
It is recommended to save the cube after this change to save your database settings. Save a cube on
page 12

Then click "refresh" to update the cube's data.Refresh cube on page 30
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Create a new connection
To create a new database connection, select Properties on the Home Tab.

Then select the "Connections" option. Then Click "Add Connection" and specify the connection details. 
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The different database driver details that can be selected are :
IBM DB2
Microsoft SQL Server
Oracle
Pervasive.SQL
ODBC
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Connect to Sage 300

Click this icon to connect to Sage 300 (formerly Accpac). You will only see this icon if a work-
station setup fromSage 300 has been run on the workstation. 
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How To Change What You View In Info-Explorer

Using Info-Explorer, you can

Create/Copy new views of your data. Click on the different views to see data organized in
a different way. In the example below, AP Outstanding Transactions, Outstanding by
Vendor Group, Outstanding with Aging, AP Outstanding by Vendor are views on the AP
query, and AR Outstanding Transactions is the view on the AR Query.

Create new charts of your data. Click on the chart to see the data represented graphically.
In the example below Outstanding Aging Chart andOutstanding by Vendor group are two
charts on the AP Query.

Create new dashboards to view multiple views and charts on the same screen. In the
example below there is one Dashboard shown at the top of the list of queries/views/charts

Create, modify, delete worksets within an existing cube, and update the underlying ERP
systemwith the selected workset

Reorder and Reorganise your views, charts and dashboards

Drag and drop the rows and columns to see data organized in a different way. In the
example below you could swap the customer and customer goup dimensions, to see a list
of customers byDateDueYear.

Sort dimension values to see columns and rows sorted ascending or descending.

Drill through to a dimension value (in Sage 300 ) to see the required dimension value in the
source data entry screen in Sage 300

Drill down to underlying transactions. Right Hand Mouse > Drill Down on a total value and
the underlying transactions that make up the total will be displayed. Data can be “copied”
and “pasted” to another application from this grid. 

Filter a dimension or fact to see a selected subset of your data. By “filtering” a required
dimension you can select/deselect the required dimension values.

Filter the underlying dimension data to see a filtered subset of your data. For example in
the AR Query, you could filter out all credit notes.

Filter the rows and columns based on calculated facts to see a filtered subset of your data.
In the AR Query, you could show only those customerswhere their total amount due was
greater than $1,000
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Create new facts to analyze based on calculated data. In the AR Query, you could rank
your customers by amount due. You can also delete a fact and amend a fact as is required. 

Format the entire cube (change the appearance of the facts in the cube, colour and font) or
format an individual fact 

Refresh the cube Refresh all cubes and set a cube to Auto-Refresh

Create parameters for your queries to restrict the data retrieved into the cube. In the AR
Query below you could restrict the customers by SalesRep.

Open a second (and third, and fourth etc) cube to displaymultiple cubes onmultiple tabs.
Highlighted in purple below

Create a new query within an existing cube, and save views on the new query. Highlighted
in yellow below

Reorder and Reorganise your views and charts
The views, charts and dashboardswithin a cube can be reordered and reorganized by dragging
and dropping the view/chart/dashboard.
Select the required view/chart/dashboard (by clicking and holding themouse button down, and
the selected view/chart/dashboard will go blue) and drag the view/chart/dashboard to the
required position as shown by the dark blue line and deselect (let go of themouse button).
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Drag and Drop Dimensions and Facts
To change your visible rows and columns on any one view, you can click on a dimension, hold your
mouse button down and drag the dimension to the area you want it to be. For example, if you wish to see
which vendor groups the vendors belong to, you click on Vendor Group, hold your left handmouse button
down, drag the Vendor Group dimension to the Left of Vendor and let it go.
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To collapse all vendors and vendor documents, click on Collapse icon on the Home Tab
> View Ribbon

To expand all vendor groups, vendors and document numbers, click on Expand icon on the Home
Tab > View  
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Sort a dimension

The sort by dimension icon toggles between sorting the dimension
in ascending and descending order.  

For example below, the Customer dimension is sorted in ascending order, the Item Number dimension in
ascending order.
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See alsoWorking with Info-Explorer - Home Tab

Viewing Facts
Drag and drop the dimension you want visible from the facts list to the title bar
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By dragging all the facts except amount due to the title bar, you will achieve :

Formula Fact

To create a formula fact, click on the Edit Fields Icon on the button on the Home Tab
> View Ribbon and choose the type of fact being "formula".

Type in the field name

Type in the field caption

Choose the value as "formula"

Type in the formula (for example BUDGETSALES.VALUE-BUDGETCOST.VALUE for a budget margin
calculation).

Select whether the totals are evaluated (recalculated based on the formula) or summed (the row/column is
added not recalculated by formula)

Select how you would like the figure displayed (absolute/percent variation, percent of column/row)

Click Save
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Note: Fact names are case sensitive

Valid Operators & their relative priorities :

Operators Priority and Example
+ , - 8 (Highest) . Eg 10+2 gives

12 
^ 7 raise to the power. EG

2^4 gives16 
/, *, div,
mod, *%,
/%

6

+, -, +%,
-%

5

<, >, < =, >
=, ==, !=

4. Comparisons return 1 if
true, 0 if false

not 3
and 2
or, xor 1
eqv 0 (Lowest)
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Working with Info-Explorer - Home Tab

You can either work with the full ribbon (as shown above), or to maximise the screen for data you
can double click on the Home tab and work with aminimised ribbon as shown below

Double clicking on the Home tab again will maximise the ribbon

From the Home tab “quick links” you can :

Open a cube

Create a new cube

Create a new tab

Connect to Sage 300 ERP

Refresh an existing cube

Refresh all or selected existing cubes

Close an existing cube
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From the Home tab “view” links you can

swap rows and columns of the active view

collapse rows and columns (hierarchy) of the active view

expand rows and columns (hierarchy) of the active view

Properties to View/Amend the cube’s properties and to set Auto Refresh

Query Builder to View/Amend the active cube’s query

Edit Fields to Create/Amend/Delete a fact

Edit Styles to change the appearance of a fact 

Edit PreFilter to create a PreFilter

Auto Calculate to view dimension changes immediately

Calculate to view dimension changeswhen clicked

From the Home tab “new” links you can

Create a new dashboard

Create a new chart

Copy view

From the Home tab “export” links you can
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export the current slice to HTML

export the current slice to CSV

export the current slice toMS Excel

Open a cube

To open a cube, go File>Open . , and select the .cubx file.

If you openmultiple cubes files, you will havemultiple tabs, one per cube file. The asterix "*" beside a
cube file name indicates unsaved changes have beenmade. If you close this cube file without saving, you
will be prompted if you want to loose the changes.  
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Refresh cube

will refresh the cube data.

If you havemultiple queries, you will see a “down arrow” below Refresh, allowing you to refresh “All
Cubes” or each individual cube in your cube file.

All current formatting, views etc will be preserved.

Swap rows and columns

Swap row/column icon allows you to toggle the rows and columns. For example below, customer is
the rows and year the column. Clicking swap rows and columns you get year as the row and customer as
the column. 
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See alsoWorking with Info-Explorer - Home Tab

Collapse rows and columns (hierarchy)

Clicking the collapse hierarchy icon will automatically collapse all hierarchies for all dimensions as
the rows and columns.
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For Example, the Customers have been "collapsed" per customer group, and can be selectively "expan-
ded" by clicking on the + sign beside the vendor

Clicking on the Expand rows and columns would expand all dimension elements.

See also Expand rows and columns

See alsoWorking with Info-Explorer
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Expand rows and columns (hierarchy)
Clicking the expand hierarchy icon will automatically expand all hierarchies for all dimensions as the
rows and columns.

For example all customer groups and customers can be "expanded" by clicking the "expand rows and
columns" button, and can be selectively "collapsed" by clicking the - sign beside the required customer
group 

Clicking on the Expand rows and columns would expand all dimension elements.

See alsoCollapse rows and columns

See alsoWorking with Info-Explorer
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Properties

Clicking Properties will allow you to define and change the existing properties of the cube.

From here you can define and change

Options : Security options for the cube. By setting a password you can restrict access to

The ability to open an entire .cubx file : Lock File

The ability to view/change the connection parameters : Lock Connections

The ability to view/change an individual cube within the file : Lock Cubes
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The ability to refresh the cube : Lock Refresh

The ability update the Sage 300 database with the currently selectedWorkset: Lock
Writeback

The ability to update the budget, forecast or what-if scenarios (Worksets)Lock Writeback

The ability to define a password which will be needed in order to write the budget/forecast
data back to Sage 300 database: Lock Write Back

The ability to define a password which will be needed in order to change the query (Lock
Writeback Query )used to write back the budget/forecast data entered in the cube to
Sage 300 database for:

- General Ledger Budget Sets

- Inventory Control Item Forecasts

- InformationManager user definable InfoSets

Parameters :
Define parameters and default valueswhen running queries. See Using Parameters in a query

Connections :
Define the database connections for each query.
See Create a new connection
See Configure to a different database

Cubes:
Click on the cube name (or “new cube” if the cube has not been renamed), and you will be able
to
• Review/change the connection for this query
• Review/amend the SQL query for the cube
• Click onQuery Builder to use theQuery Builder to amend the SQLQuery. SeeQuery Builder

+Views
Expand the + beside Views under each cube and you will see all the views defined on the cur-
rent query.
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+Write back
Expand the + besideWriteback to see all the facts in the current cube. By clicking on any one of
the facts you will be able to define a SQL query to write the selected fact back from aworkset to
the underlying ERP database. SeeWriteBack
Please note: Write Back is not standard feature and must be purchased

The total number of records in the cube will be displayed.
The current key defined for the worksets will be displayed (the relevant dimensionswill be in
bold).
To view the records, click “view records”
To define the key dimensions, click “Define Key Fields”. See Define Key Fields

Auto Refresh:
Enter the number of minutes after which the currently active cube view will refresh. If zero, then
the cube will not auto refresh. The “count down” clock on the top right hand side of the ribbon will
show when the cube will next refresh.

See AlsoWorking with Info-Explorer – Home Tab

Query Builder

Click this icon to view/amend the existing query for the active cube.

Use theQuery builder to assist in creating your query. Here you can

Double click on the table name to add the table to your query

Select the columns required by clicking on the tick box to the left of the column name or type
the column name in the expression box

Type in the aggregate function (if required)

Type in an Alias (if required)

Select Sort Type and Sort Order andGroup by if required

Test the query by clicking on the data tab to view the results

To join tables, click on the column in the first table and drag to the second table. The join
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type can be amended by double clicking on the line joining the tables

Type in functions (for example Rtrim) in the Expressionswindow

When complete, click File\ok and the new cube will be created in the workbook

The sql query can also be typed/amended in the SQL Pane

See alsoUsing Parameters in the query

See alsoWorking with Info-Explorer – Home Tab
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Using Parameters in the Query

After building the query (or pasting in the query from another query builder tool), you can add parameters
which can restrict the data to be viewed. The parameters can either be visible/amendable by the users
when "refresh" is clicked, or hidden. 

To add a new parameter, click on the Properties icon

Click "Add Parameter" to add a new parameter, or click the existing parameter to amend an existing para-
meter :

Per parameter you can define:
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The parameter Name

The parameter Label

The parameter tool tip description

an optional default value

set if it is a hidden parameter

After defining the parameters, thesemust be edited into the query as is required - between% symbols.
For example "FROMFISCALYEAR" and :TOFISCALYEAR" as shown in red below : 

SELECT rtrim(A.ACCTSEGVAL)+' - '+rtrim(A.ACCTDESC) AS Account, rtrim(A.ACSEGVAL02)+' -
'+rtrim(S1.SEGVALDESC) AS SEGMENT1, rtrim(A.ACSEGVAL03)+' - '+rtrim(S2.SEGVALDESC) AS
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SEGMENT2, rtrim(A.ACSEGVAL04)+' - '+rtrim(S3.SEGVALDESC) AS SEGMENT3, rtrim
(A.ACCTGRPSCD)+' - '+rtrim(GRP.ACCTGRPDES) AS AccountGroup, CASE rtrim(A.ACCTTYPE)
WHEN 'B' THEN 'Balance Sheet' ELSE 'Income Statement' END AS AccountType, F.FSCSYR, '01' AS
Period, (case when F.FSCSDSG = 'A' then (F.OPENBAL + F.NETPERD1) else 0 end) AS Actual,
(case when F.FSCSDSG = '1' then (F.OPENBAL + F.NETPERD1) else 0 end) AS Budget1 
FROMGLAMF AS A LEFT OUTER JOIN GLASV AS S1ON A.ACSEGVAL02 = S1.SEGVAL AND
S1.IDSEG = '000002'
LEFT OUTER JOIN GLASV AS S2ON A.ACSEGVAL03 = S2.SEGVAL AND S2.IDSEG = '000003'
LEFT OUTER JOIN GLASV AS S3ON A.ACSEGVAL04 = S3.SEGVAL AND S3.IDSEG = '000004'
LEFT OUTER JOIN GLACGRP AS GRP ON A.ACCTGRPSCD = GRP.ACCTGRPCOD
LEFT OUTER JOIN GLAFS AS F ON A.ACCTID = F.ACCTID AND F.CURNTYPE = 'F' and FSCSYR
>= %FROMFISCALYEAR% and FSCSYR <= %TOFISCALYEAR%

See alsoCreating a cube

See alsoWorking with Info-Explorer - Home Tab

Create a fact/Amend a fact/Delete a fact

To change the format (appearance) of a fact or create a fact, click on the Edit button

41 of 82 Working with Info-Explorer - Home Tab



Orchid Modules

To Delete a Fact

Select the appropriate fact from the fact list on the left hand side of the Fact/Formula edit
window
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Click the Delete button.

Click Save after deleting.

To Amend a Fact

Select the appropriate fact from the fact list on the left hand side of the Fact/Formula edit
window

Change the caption of the Fact.

Change the Value of the field if required

Change the Display as of the field as required

Click Save after changing

To Create a Fact

Select "Create New fact" on the fact list on the left hand side of the Fact/Formula edit win-
dow and fill in the details as are required

Assign the Fact a Name (for exampleMarginP)

Assign the Fact a Caption (for exampleMargin%)

In the Value field, select the calculation type

Formula to define your own calculation in the Formula box (for exampleMargin% shown
below

Sum - to total the fact defined in the "Of Field"

Number of records in "Of Field"

Minimum - to display theminimumof values in "Of Field"

Maximum - to display themaximumof values in "Of Field"

Average - to display the average of values in "Of Field"
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Ascending Rank - to display the relative rank of values in "Of Field", lowest is 1

Descending Rank - to display the relative rank of values in "Of Field", highest is

In the Formula or Of Field

Formula : Type in themathematical formula as required based on the facts retrieved by
the query (for exampleMargin would be) See Formula Fact

NetSales.Value - Cost.Value)     

Of Field : Select the fact required. These are the facts retrieved by the query, not for-
mulas themselves.

In the Display as field, select the display type for the field selected

Default - to show as calculated

Absolute variation - shows the absolute variation of the current column against the prior
(visible) period

Percent variation - shows the percetage variation of the current column against the prior
(visible) period

Percent of column - to show the calculated field as a percentage of the column it is in (for
example Percent of Total shown below)

Percent of row - to show the calculated field as a percentage of the row it is in

Click Save to save changesmade on the Fact/Formula editor

See AlsoWorking with Info-Explorer - Home Tab

Amend a formula fact

To change a fact, click on the Edit Fields Button andmake the change required
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See also Creating a Fact
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See alsoWorking with Info-Explorer

Format a fact
Changing the caption

To change the caption of a fact, click on the Edit Fields button on the Home Tab
> View Ribbon
Select a Fact and change the caption. Click Save after changing
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Changing the Style

Change the style of any Fact (or the whole cube) click on the button on the Home
Tab > View Ribbon . First create the required style, and then apply it to the required fact. For
example for Traffic light reporting, create a Style for TrafficLightGreen, TrafficLightOrange and
TrafficLightGreen  
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And apply the new style to the required fact
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See Format a cube - Styles below

Format a cube - Styles
Using Styles to format a cube

To change the format (appearance) of a fact or all facts, click on the Edit button on the
Home tab>View Ribbon.

Create the styles required. For example, create a style for totals with a blue background colour
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and apply the style to the cube by selecting "Rules for this cube"
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See Format a fact on page 46

Filter a dimension or fact
There are three ways to filter a dimension

filter using a tick box (on/off)

filter using a prefilter on the underlying dimension values

filter using calculated fact values

51 of 82 Working with Info-Explorer - Home Tab



Orchid Modules

Filter using a tick box :
To filter a dimension, hover over the required dimension to activate that dimension and then click

on the small filter icon on the dimension title
and then selectively turn on/of the items required

If a dimension is already filtered, then the filter icon will always be visible. If a dimension is not
already filtered, then the filter icon will only be visible when you click on the dimension title.

Filter using a prefilter on the underlying dimension values :

Alternatively, click on Edit PreFilter on the Home Tab > View Ribbon to filter using a pre-
filter on the underlying dimension values, right handmouse button on the dimension and select Show Pre-
filter
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and build the filter string as required :
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you can apply multiple conditions

the current filter shows at the bottom of the screen

Note, the text filter is case sensitive

to remove a filter, click the red x on the appropriate row
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Filter using Calculated fact values
Alternatively, to filter using a filter applied to calculated values and totals, click on the Calculated
values filter on the required dimension

and build the filter string as required. In this case the Facts you can select from are based on the visible
columns, and you can select “Any one” or “All” or “one specific” column. 

In the example below, we are going to filter All vendors where for Every year, the Amount Due > 100 (not
any one year or a specific year for example 2020). As with the prefilter, the current filter shows at the bot-
tom of the screen and works in conjunction with the prefilter (if any).
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Filter Calculated Fact Values

The filter calculated fact values allows you to build filters on columns by
row data, or rows by column data.

Click on the red calculated values filter and build the filter string as required.

When selected on a row dimension, you can filter all the rows based on

The grand total being compared to your condition

Every column compared to your condition

At least one column compared to your condition

A specific column compared to your condition

In the example below you can filter customers
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where the grand total of net sales is greater than 1000

where every year (2019, 2020) has net sales greater than 1000

where any one year (2019, 2020) has net sales greater than 1000

a specific year (2019 or 2020) has net sales greater than 1000

You can applymultiple calculated fact filters, and are shown at the bottom of the InfoExplorer
screen.

In the following example:

a prefilter has been applied to not include any itemswhere the category is ZZZ, and then to
filter the Customer (prefilter show in black)
NetSales > 500 for every year (calculated fact filter show in blue)

Cost > 600 for every year (calculated fact filter shown in blue)

To amend an existing filter, click on the blue hyperlink at the bottom of the screen, or click on the
red "Filter" on the dimension.

To amend an existing prefilter, click on the pre-filter button or right-handmouse button on the rel-
evant dimension and select "Edit Prefilter".
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To remove a filter, click the red x on the appropriate row
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AutoCalculate

Click this icon to ensure that each time you drag & drop a dimension, the visible grid will re-
calculate. 

Deselect this option if you want to do a number of dimension changes, and re-calculate
when all the changes have been done. 

If the button is highlighted "gold” it is selected. 

If the button is not highlighted it is deselected. 
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If Auto Calculate is deselected and changes have beenmade, the Calculate button,is
shown, whichmust be clicked to view dimension changes

See alsoCalculate
Calculate

Click this icon to re-calculate the dimension/view changesmade since Calculate was last
clicked. This icon is only shownwhen Auto Calculate is not selected.  

If the button is highlighted "gold” it is selected.

If the button is not highlighted it is not selected

See also Auto Calculate

Create a dashboard

Create a new dashboard by

clicking Create dashboard icon on the Home Tab > New Ribbon or

Right HandMouse Button on a View or chart name and Select New dashboard

By default a New dashboard has 3 rows and 3 columns, allowing you to drag & drop 9 views or charts
from the current cube to the dashboard.

Use “Create Row” , “Create Column”, “Remove Row” and “Remove Column” to adjust the dashboard size
to have as many rows and columns as are required.  

Drag and drop the required views & charts from the available cube to the dashboard.

Select the Close on any individual dashboard view/chart to deselect this item.
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For example, the following dashboard has 2 rows, and 1 column
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Create a New Chart

Create a new chart by first selecting the View you want to base the chart on, and then

Clicking Create chart icon on the Home tab > New ribbon

Right HandMouse Button on the selected View and selecting New Chart, or Click New
Chart on the Home Tab > New Ribbon.
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From the New Chart window, you can select the File menu and :
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Save the new chart

Save as the new chart to assign a name and add the chart to the cube file

Change the Chart Type to one of Line, Bar or Pie

Swap the Chart axis (ie swap the x and y axes)

Selectively show the Chart Labels

Change the Chart Properties

Close the chart

From the New Chart window, you can select the Legendmenu and select where the legend is to
show 
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From the New Chart window, you can select the Datapointsmenu and select what datapoints
are to show 

Export to CSV
Note, if you are using Info-Explorer Lite, then "create cube", "export to csv", "export to HTML" and "export
to Excel" are not available

To export the current slice to a CSV (comma separated values) file, click the Export to CSV icon and
provide the appropriate file path and file name.
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See AlsoWorking with Info-Explorer - Home Tab

Export to HTML
Note, if you are using Info-Explorer Lite, then "create cube", "export to csv", "export to HTML" and
"export to Excel" are not available

To export the current slice to a HTML file, click the Export to HTML icon and provide the appropriate file
path and file name.

See AlsoWorking with Info-Explorer - Home Tab

Export to MS Excel
Note:
if you are using Info-Explorer Lite, then "create cube", "export to csv", "export to HTML" , "export to MS Excel"
and "Worksets" are not available.
Worksets and Writeback are only available if the Info Explorer - Write back licence has been purchased and
activated. If you are using "info-Explorer - Full", then "Worksets" and writeback are not available.

To export the current slice to aMS Excel file, click the Export to MS Excel icon or the Home Tab > Export
Ribbon and provide the appropriate file path and file name

Working with Info-Explorer - Home Tab 66 of 82



Orchid Modules

67 of 82 Working with Info-Explorer - Home Tab



Orchid Modules

Working with Info-Explorer – Chart Tab
When the active view is a chart, the Chart tab is visible

From the Chart tab “quick links” you can :

Save : to save the current chart

Save as: to save the current chart to a new name

Properties : to review the chart properties 

Swap Axis : to swap the x and y axis of the current line chart

From the Chart tab “style” links you can change the current chart style to : 

Line : to select a Line Chart  

Bar : to select a Bar Chart 

Pie : to select a Bar Chart 

From the Chart tab “Labels” links you can selectively show labels : 
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Left : to select a left or x axis labels 

Bottom: to select a bottom or y axis labels 

From the Chart tab “Legend ” links you can change the legend position on the currently active
chart: 

None: to have no chart legend 

Left: to the chart legend on the left 

Right: to the chart legend on the right   

Top: to the chart legend on the top 

Bottom: to the chart legend on the bottom 

From the Chart tab “Datapoints ” links you can selectively show symbols for the datapoints on a
line chart : 

None: no symbol for data points shown

Square: square symbol for data points shown

Circle: square symbol for data points shown 

Diamond: diamond symbol for data points shown

Triangle up: triangle up symbol for data points shown
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Triangle down: triangle down symbol for data points shown 

Cross: cross symbol for data points shown 

Plus: plus symbol for data points shown

Star: star symbol for data points shown 

Vertical Dash: vertical dash symbol for data points shown

Horizontal Dash: horizontal dash symbol for data points shown 
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Working with Info-Explorer – Dashboard Tab
When the active view is a dashboard, the dashboard tab is visible

From the Dashboard tab “quick links” you can :

Add Row : add a row to the currently active dashboard 

Remove Row : remove a row from the currently active dashboard 

Add Column: add a column to the currently active dashboard  

Remove Column: remove a column from the currently active dashboard  
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Working with Info-Explorer – Display Tab
From the Display tab, you can control:

• Which titles are visible

•Which totals are visible

• If the entire view is scaled to the nearest one (1), ten (10), hundred (100) or thousand (1,000)

With all the following options

When “Selected” or “on”, the option will be highlighted in orange,
and the option will be shown.

When “De-Selected” or “off”, the option will not be highlighted
and the option will not be shown.
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From the Display tab, “Titles” links you can

Show the Tree area.

Show the Available Fields area.

Show the Displayed Fields area.

Show the Row titles

Show the Column titles

From the Display tab, “Totals” links you can

Show the Row Totals

Show the Row Grand Totals

Show the Column Totals

Show the ColumnGrand Totals

From the Display tab “scale” links you can change the scale used to display the data

1x1 scale the data

This is the default selection and implies no scaling. For example 4,304.84 is displayed as
4,304.84

1x10 scale the data

To see your data rounded to 10's. For example, 4,304.84 is displayed as 430.48

1x100 scale the data

To see your data rounded to 100's. For example, 4,304.84 is displayed as 43.05
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1x1,000 scale the data

To see your data rounded to 1000's. For example 4,304.84 is displayed as 4.30
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Working with Info-Explorer – Workset Tab
Requirement! You need a “Budget and Writeback” licence to view the Workset tab.

From theWorkset tab, "Workset” links you can

Create a newWorkset

Delete and existingWorkset

Copy an existingWorkset

Rename aWorksheet

Write back a workset to underlying ERP

To amend a budget, forecast or scenario figure, double click on the cell and change the value. If
this cell ismade up of a single record, then the single value will be updated. If the cell you have
changed is a total of a number of records, then the total will be amended by updating the under-
lying records. The underlying recordswill be updated according to the selected “Spread” method.
The available spreadmethods are :
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Evenly : The total value entered is divided by the number of recordsmaking up the total,
and this equal value is spread to all he underlying records
Proportionally : When thismethod is selected, you need to specify which values are to form
the basis of the spread – the current value in theWorkset, or the original value of the work-
set before any changesweremade. Additionally you can spread proportionally based on a
different dimension value. In the example below, any changes to the budget figure will be
spread based on the existing current values in the “Actual” version.

Minimum only : The total value entered is assigned to the single record which has the minimum value of
the underlying records
Maximum only: The total value entered is assigned to the single record which has the maximum value of
the underlying records
Average : The value entered is the average value, and will be assigned to all records making up the
total.
Percentage increase/decrease: The total percentage value entered is applied to all the records making
up the total. To increase all records by 10%, enter “10”. To decrease all records by 10%, enter “-10”.
Absolute increase/decrease: The absolute value entered is applied to all the records making up the
total. To increase all records by $100, enter “100”. To decrease all records by $100, enter “-100”.
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Writeback
Warning!With a “Budget and Writeback” licence, you are able to view the Workset tab and use the Writeback
functionality.

Once the required fact has been selected, the SQL query to be executed for each amended fact
will be displayed.

The sql query will be executed for all amended facts. You can include dimension values from your
cube by including them in the SQL statement, surrounded by percent signs (%).

The amended budget, forecast or scenario figuresmust be included from your cube by including
the fact as%VALUE%

There are 3 supported write back queries for Sage 300

GL Budgets

InformationManager Infosets

IC ItemProjected Sales

No new recordswill be created in the Sage 300 database.

to update aGL budget for an account/fiscal year/fiscal period combination – the budget
recordmust already exist in Sage 300. So youmight need to import zero for all account-
s/fiscal year/fiscal periods required.
to update an informationmanager infoset, the initial recordmust be inserted for the key
combination and date required. So youmight need to use an import/export into Infosets, or
the InformationManager Excel add-in to create new records
to update IC Item projected sales, the intial record(s) must be imported into the IC reorder
table

Example SQL queries:

Example SQL query to update GL Budgets:

For a specific site, the sample cube would need adapting.
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Included dimensions included in percentage signs%xxx%, and are highlighted in yellow
The budget, forecast or scenario data entered is always called%VALUE% shown in green
below
The sql query is shown in blue text below
Hard coded fields in red (currency, budget set and currency type) would need amending
per customer site

DECLARE@SQLVARCHAR(MAX);
DECLARE@columnnameVARCHAR(10);
DECLARE@period VARCHAR(2);
DECLARE@currency VARCHAR(3);
DECLARE@fscdsg VARCHAR(1);
DECLARE@curntype VARCHAR(1);
SET@currency = N'CAD';
SET@fscdsg = N'1';
SET@curntype = N'F';
SET@period = N'%PERIOD%';
SET@columnname = N'NETPERD' +
case left(@period,1) when '0' then RIGHT(rtrim(@period),1) else RIGHT(rtrim(@peri-
od),2) end;
SET@SQL = 'UPDATE GLAFS set ' + @columnname + ' = %VALUE%WHERE RTRIM
(ACCTID) = ''%UNFORMATTEDACCOUNT%'' AND FSCSYR = ''%FISCALYEAR%''
AND FSCSCURN = ''' + @currency +
''' AND FSCSDSG= ''' + @fscdsg + ''' AND CURNTYPE = ''' + @curntype + ''';'
EXEC (@SQL);

Example SQL query to update Customer/ItemBudgets:

This query is designed to update a Customer/Item budget stored in an InformationMan-
ager infoset. There are facts which can be entered, Budget Quantity, Budget Sales and
Budget Cost

Included dimensions included in percentage signs%xxx%, and are highlighted in yellow
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The budget, forecast or scenario data entered is always called%VALUE% shown in green
below
The sql query is shown in blue text below
Hard coded variables whichmight require changing per customer site are shown in red text
below

a. SQLQuery for fact BUDQTY

DECLARE@SQLVARCHAR(MAX);
DECLARE@infokey as VARCHAR(10) = CONVERT(VARCHAR(10),'%INFOKEY%');
DECLARE@optfield as VARCHAR(10) = N'BUDQTY';
SET@SQL = 'UPDATE EBINFOOset VALUE = %VALUE%WHERE INFOKEY = ' +
@infokey +
' AND RTRIM(OPTFIELD) = ''' + @optfield + ''' ;' ;
EXEC (@SQL);

b. SQLQuery for fact BUDCOST

DECLARE@SQLVARCHAR(MAX);
DECLARE@infokey as VARCHAR(10) = CONVERT(VARCHAR(10),'%INFOKEY%');
DECLARE@optfield as VARCHAR(10) = N'BUDCOST';
SET@SQL = 'UPDATE EBINFOOset VALUE = %VALUE%WHERE INFOKEY = ' +
@infokey +
' AND RTRIM(OPTFIELD) = ''' + @optfield + ''' ;' ;
EXEC (@SQL);

c. SQLQuery for fact BUDVALUE

DECLARE@SQLVARCHAR(MAX);
DECLARE@infokey as VARCHAR(10) = CONVERT(VARCHAR(10),'%INFOKEY%');
DECLARE@optfield as VARCHAR(10) = N'BUDCOST';
SET@SQL = 'UPDATE EBINFOOset VALUE = %VALUE%WHERE INFOKEY = ' +
@infokey +
' AND RTRIM(OPTFIELD) = ''' + @optfield + ''' ;' ;

79 of 82 Writeback



Orchid Modules

EXEC (@SQL);

Example SQL query to update IC ItemProjected Sales Budgets:

This query is designed to update a Customer/Item budget stored in an InformationMan-
ager infoset. There are facts which can be entered, Budget Quantity, Budget Sales and
Budget Cost

Included dimensions included in percentage signs%xxx%, and are highlighted in yellow
The budget, forecast or scenario data entered is always called%VALUE% shown in green
below
The sql query is shown in blue text below

DECLARE@SQLVARCHAR(MAX);
DECLARE@periodstart as VARCHAR(8) = CONVERT(VARCHAR
(9),'%PERIODSTART%',112);
DECLARE@itemno as VARCHAR(24) = N'%ITEMNO%';
DECLARE@location as VARCHAR(10) = N'%LOCATION%';
SET@SQL = 'UPDATE ICREORD set SALESPROJ = %VALUE%WHERE RTRIM
(ITEMNO) = ''' + @itemno +
''' AND LOCATION = ''' + @location + ''' and PERIODSTRT = ' + @periodstart + ' ;' ;
EXEC (@SQL);
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